Home  |  Discuss  |  Donate  |  Contact  |  About 

ftp permissions

Hardware, Software, Internet, etc.

Moderators: Big-O Ryan, Big-O Mark, Matt, jester22c

ftp permissions

Postby Boss1315 » Tue Apr 20, 2004 6:31 am

Hi,
On my apache dedicated server, i had a forum for somebody on my cPanel account(cawunited) as a subdomain(cawunited.com/whatever). And, i made them a new domain hosting account via the WebHostManager. Then, i used ssh to copy the folder from cawunited.com to their domain. Now, whenever they go to change permissions or upload files to anywhere inside that folder, it doesnt work.. It either says Access Denied, or Bad File Descriptor. Does anyone know how i can fix this?

Thanks,
Boss
~ :P Why put off something until tomorrow,
When you can do it the day after? :P ~
http://e.1asphost.com/boss1315/?sn=bigosig

Make Money with paypal!
http://www.dollars-for-you.com/plan1/index.php?ref=8432
User avatar
Boss1315
Newbie
Newbie
 
Posts: 6
Joined: Wed Dec 18, 2002 6:15 pm
Location: PA

Postby fuuucckkers » Tue Apr 20, 2004 12:42 pm

Well for one thing. a subdomain is 'name.domain.com' -- not 'name.com/name' -- could be the problem.

But then again, if it's access denied. It's probably just the folder/ file permissions on that specific directory.


Also, make sure you add the correct settings to the Virtual Directory section in your httpd.conf file.
And again, also.. make sure you also add a Directory section as well, to add permissions to access that area as well.
Code: Select all
<Directory /var/www/html/subdomain>
   AllowOverride All
   Options ExecCGI
   <IfModule mod_access.c>
   Order allow,deny
   Allow from all
   </IfModule>
</Directory>
fuuucckkers
Moderator
Moderator
 
Posts: 815
Joined: Sun Sep 22, 2002 3:33 pm

Postby BigHead » Tue Apr 20, 2004 1:34 pm

If this is a linux box make sure the folder and the files in it have the correct ownershipe
BigHead
~2592~
BigHead
Fanatic
Fanatic
 
Posts: 127
Joined: Thu Nov 14, 2002 8:25 pm
Location: somewere in the USA

Postby fuuucckkers » Wed Apr 21, 2004 10:45 am

BigHead wrote:If this is a linux box make sure the folder and the files in it have the correct ownershipe


Yes.... and you're just repeating what I already said.
It's probably just the folder/ file permissions on that specific directory.



:roll: :D
fuuucckkers
Moderator
Moderator
 
Posts: 815
Joined: Sun Sep 22, 2002 3:33 pm

Postby sweeney » Tue May 04, 2004 12:50 pm

I figured I'd post in this topic since it's semi-related to my problem. I have a folder on my server where I put pictures I like. How do I allow access to this folder directly, rather than making an index page which I would have to update every time I added a picture?
Axilla wrote:Since apparently no one has told you what a huge douche bag you are, I'll just tell you now. You are a huge douche bag. Huge.
User avatar
sweeney
Addict
Addict
 
Posts: 88
Joined: Fri Oct 18, 2002 2:24 pm
Location: Hamden, CT

Postby fuuucckkers » Tue May 04, 2004 1:31 pm

Well.. you didn't mention what OS, or what Server Software you have. I assume Windows and IIS.. but either Windows or Linux (with Apache).. it's all relatively the same.

For Linux and Apache... in your .htaccess file, or in the httpd.conf file ... you need to add "Options Indexes".

So it'll look like this.

Code: Select all

<Directory /path/to/files>
.........
.........
Options Indexes
</Directory>



And for Windows.. with IIS find an option to turn "Indexing" on. If it's Windows with Apache... you'll need to use change your httpd.conf file to add the option from the code above.
fuuucckkers
Moderator
Moderator
 
Posts: 815
Joined: Sun Sep 22, 2002 3:33 pm

Postby sweeney » Tue May 04, 2004 1:44 pm

Errr...sorry for the lack of details, but a friend of mine just lets me use some of his server, I'm not too sure of what it is.
Axilla wrote:Since apparently no one has told you what a huge douche bag you are, I'll just tell you now. You are a huge douche bag. Huge.
User avatar
sweeney
Addict
Addict
 
Posts: 88
Joined: Fri Oct 18, 2002 2:24 pm
Location: Hamden, CT

Postby BigHead » Tue May 04, 2004 6:42 pm

well since WHM/Cpanel doesn't run on windows it is linux :wink: you need to find out what ownership the files need to have and then do "chown -rf user:group /path/to/directory/" replacing user and group with the right stuff

EDIT: it is a responce to your first question not second
BigHead
~2592~
BigHead
Fanatic
Fanatic
 
Posts: 127
Joined: Thu Nov 14, 2002 8:25 pm
Location: somewere in the USA


Return to Totally Off-Topic Computers

Who is online

Users browsing this forum: No registered users and 1 guest

cron